Mining wallet still having serious sync issues with v0.29.0


I made an account to come let you guys know that v0.29.0 seems to still be having serious issues syncing. I mined into this wallet for a couple of months (with daily payments from F2Pool). I have had every iteration of this wallet since November last year and they have all had issues syncing.

v0.29.0 excited me, since it was supposed to fix the bug with mining wallet sync and that’s clearly my situation - however it’s the same if not worse than 0.28 was for me. I have cleared cache at least twice now. Since the last clear cache it has been 2 or 3 days and I am still only up to block 511,977 and it has slowed to a crawl. For example, it did not progress at all while I wrote this post.

Please let me know if there is anything I should try, anything I can provide to help, or if we just have to wait for another version update.

Windows 10 Pro 64
3900X / 5700XT
500GB M.2 SSD

On a side note, does this wallet store CKB blockchain data on the local machine? If so, where, and can we add an option to change it? I would rather it not jam up my main SSD and instead point it to my dedicated crypto HDD. Of course if it isn’t stored anywhere locally this is a non issue.


Hey sam, sorry you still have issue syncing with v0.29.0. I’ll try to clear a few things out.

a) v0.29.0 does fix several very serious syncing issues, especially for miner wallet.

b) The issue you’re seeing is due to a bug of the CKB node. It becomes slow when approaching 400k to 500k blocks under certain circumstances. We have a pending fix for that, but for now if you’d like to test the fix you have to download and run a prerelease of CKB from

c) Yes the wallet stores CKB data locally. It has a bundled CKB node running with it. If you run a CKB node (for example v0.31.0-rc1 as b) describes) yourself and launch Neuron wallet, then Neuron will NOT start the bundled node, but connects to your node instead.

d) Running CKB node and storing data to your chosen hard disk is doable (please check the ckb init command). But using HDD is way slower than HDD since blockchain sync involves a lot of IO operations. Besides, CKB is optimized with SSD; it’s common to be slower when running and storing data on HDD.

Hope these help.


a) no doubt it does! Just not mine it seems.

b) Thanks! I’ll try running that prerelease node and see if it fixes things :slight_smile:

d) I see the option in the separate node, I’ll have a better look in the next Neuron release and see if I can figure it out. I’m not really good at command line work to be honest.

It’s all working and synced with the prerelease node :slight_smile:
Installed the node, let it catch up, then ran Neuron and cleared its cache (not sure that part was necessary). An hour or two later Neuron is fully synced and working fine.


Really glad to hear that :clap:

I’m still getting issues syncing with the latest 029 version and I tried to run the node ckb_v0.31.0-rc1 but all i get is ‘synchronizing’ under Mainnet (current block 780,610). I tried clearing the cache, but unable to sync any higher than block 780,658.

I have multiple mining payouts that are visible on the blockchain with verified confirmations.

Wallet is running on a Win10 system build 1903.

Managed to get my wallet to sync up correctly by first running the node v0.31.0-rc1, then Neuron. It is slow to sync up (I have fiber channel 1gbps connection), but it works. Hopefully a permanent fix will be implement soon because having a stable wallet is critical.

How slow? If it’s a matter of several hours then it’s normal. If it’s days then it’s really slow :rofl:

Took several hours, but now the wallet is synced (when running node ckb_v0.31.0-rc1 in the background).

1 Like

Node failed as of today and lost complete sync again. I’m looking at another wallet and installed on android as your windows wallet is just problematic and frankly taking way too much of my time to resolve. Hopefully you’ll release a stable fix update to this soon.